シナプス技術者ブログ

シナプスの技術者公式ブログ。インターネットで、鹿児島の毎日を笑顔にします。

小学生向け職場見学会『シナプスキッズデー』を実施します!!

シナプス技術部ネットワーク課の上曽山と申します。
突然ですが、来る7月28日、8月4日に『シナプスキッズデー』という職場見学会を実施します。

イベント内容

当日行う内容は以下の通りです。

・名刺交換
・フロアツアー
 (店舗、サポートセンター、事務所、データセンター見学)
・インターネットあんぜんあんしん講話
・つくってみようLANケーブル
・トラブル発生!鹿児島のネットワークを救え!
 (データセンター障害対応体験)

最初は当日のデータセンター案内だけで済むと思っていたんですが、内容を詰めていった結果、準備段階から色々とお手伝いする事になりました。

こちらからお申込いただけますので、ご興味のある方は是非ご応募ください!!

データセンター障害対応体験

障害対応体験と言うと少々おおげさな感じもしますが、体験していただくのは2台のスイッチ間でLANケーブルをつなぎ替え、疎通が取れるポートを探す、という簡単な作業です。 f:id:kanimisoya:20190710122209j:plain 演習プログラムを開始すると上記の画面が表示され、緊張感を煽るBGMと共にカウントダウンが始まります。 f:id:kanimisoya:20190710122303j:plain 正しい組み合わせでケーブルを接続すると復旧が進みます。
時間経過と共にBGMも変化していき、さらに緊張感が高まります。

f:id:kanimisoya:20190710122554j:plainf:id:kanimisoya:20190710122612j:plain

すべて復旧すれば成功画面に切り替わり拍手と喝采が、時間切れになるとブーイングが、延々と続きます。

スイッチ構成

そろそろ技術的な話をしたいと思います。
物理的な構成は下記の通り、単純なものです。
スイッチ2台の特定ポートにVLANを各々割り当て、正しい組み合わせの時だけ目的アドレスにpingが通るよう設定します。 f:id:kanimisoya:20190710160138j:plain

L2スイッチでスタティックルーティング

今回使用したスイッチは8ポートのCatalyst2960Gです。コイツはL2スイッチでありながらIPルーティングをサポートしています
とはいえ、スタティックルートしか書けないので、L3スイッチの代わりにはなりませんが。

sdmテンプレート変更

デフォルトのままでは設定コマンドすら入りません。 sdmテンプレートの変更が必要です。
※IOSのバージョンによってはテンプレートを変更しなくても設定できます。

Switch(config)#ip route
                   ^
% Invalid input detected at '^' marker.

configureモードでsdmテンプレートを『lanbase-routing』に変更します。

Switch(config)#sdm prefer lanbase-routing
Changes to the running SDM preferences have been stored, but cannot take effect
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.

変更後、スイッチを再起動(reload)することでスタティックルート設定が行えるようになります。

VLAN設定

次にVLANの設定です。
VLAN-IFにIPアドレスを割り当て、物理IFに紐づけます。
物理IFにはportfastの設定も追加します。
※Switch1のGi0/8はPC接続用IFです。

  • Switch1
interface Vlan1
 ip address 192.168.100.1 255.255.255.0

interface Vlan101
 ip address 192.168.101.1 255.255.255.0

interface Vlan102
 ip address 192.168.102.1 255.255.255.0

interface Vlan103
 ip address 192.168.103.1 255.255.255.0

interface GigabitEthernet0/1
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast

interface GigabitEthernet0/2
 switchport access vlan 102
 switchport mode access
 spanning-tree portfast

interface GigabitEthernet0/3
 switchport access vlan 103
 switchport mode access
 spanning-tree portfast

interface GigabitEthernet0/8
 switchport mode access
 spanning-tree portfast
  • Switch2
interface Vlan101
 ip address 192.168.101.2 255.255.255.0

interface Vlan102
 ip address 192.168.102.2 255.255.255.0

interface Vlan103
 ip address 192.168.103.2 255.255.255.0

interface GigabitEthernet0/1
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast

interface GigabitEthernet0/2
 switchport access vlan 102
 switchport mode access
 spanning-tree portfast

interface GigabitEthernet0/3
 switchport access vlan 103
 switchport mode access
 spanning-tree portfast

スタティックルート設定

先程設定したVLAN-IFを宛先にしたスタティックルートを書きます。
Switch2側はループバックアドレスを3つ持たせて、それぞれのIPアドレスでpingが通るようにします。

  • Switch1
ip routing

ip route 192.168.0.2 255.255.255.255 Vlan101
ip route 192.168.0.3 255.255.255.255 Vlan102
ip route 192.168.0.4 255.255.255.255 Vlan103
  • Switch2
ip routing

interface Loopback0
 ip address 192.168.0.2 255.255.255.255
 ip address 192.168.0.3 255.255.255.255 secondary
 ip address 192.168.0.4 255.255.255.255 secondary

ip route 192.168.100.0 255.255.255.0 Vlan101
ip route 192.168.100.0 255.255.255.0 Vlan102
ip route 192.168.100.0 255.255.255.0 Vlan103

戻りパケット分(Switch2側)のスタティックルートがキモチ悪いけど、他に良い書き方を思いつかなかった……。

設定は以上です。 上記の設定だと、Gi0/1同士をつないだ時は『192.168.0.2』に、GI0/2同士だと『192.168.0.3』にpingが通るようになります。

実用性は全くありませんが、こういう事もできるんだなぁ、ということで良い経験になりました。

最後に

他にも『つくってみようLANケーブル』のコーナーでは参加者の皆さんにLANケーブル作成を体験していただきます。ケーブルは8色の中からお好きなものを選んでいただけるよう準備しております。 f:id:kanimisoya:20190710181850j:plain

繰り返しになりますが、こちらからお申込いただけますので、ご興味のある方は是非ご応募ください!!